Windows 10 |The device is being used by another application

Hello guys

Greetings! Yes, I know it was a long break. Trust me, I wanted to post many things, couldn’t as I was too busy (doing my actual job, traveling etc ;) )

Anyway, Windows 10 is never packed with less surprises. Recently I was going through a 4K video clip with multilingual audio tracks & realized that the much celebrated VLC player cannot play it, when the default Movie & TV windows app played the clip without a single break or lag. However, as soon as I tried to switch the default language from “Arabic” to “English” I started getting the error “The device is being used by another application” & the app stopped playing the video (lands on the gallery actually)

I was lucky enough to land on a page with correct solution. https://blog.pcrisk.com/windows/12516-how-to-fix-the-device-is-being-used-by-another-application & “Disable Allow Applications To Take Exclusive Control Of This Device Option” section helped me to finally get over with this major annoyance. Not just that, once done, the app remembers the audio track that you selected & plays the same when you open the same video clip next time! unlike VLC player.

If you landed on this page, looking for a solution, please go through the blog from pcrisk.com & they have multiple solutions to this issue and one of the solutions listed there should help you also.

Hope it helps few out there!

regards,

rajesh

Windows 10 1903 | Oracle VirtualBox virtual machines will not start/open

Hello guys

This is a quick post towards one of the issues I faced once after enabling Windows Sandbox feature that was made available with Windows 10 1903. As Sandbox feature utilizes Hyper-V (regardless whether you have enabled it or not).

Once Sandbox feature enabled, Oracle VirtualBox 6.0.x fails to launch the Virtual Machines.

Although VirtualBox 6.0.x are supposed to support Hyper-V for acceleration, my attempts were futile, forcing me to disable the Sandbox feature, enter BIOS and browse through the virtualization settings.

I can’t say what has resolved the issues. I disabled Sandbox, restarted the box, was unable to launch the Virtual Machines.

Restarted the laptop, entered BIOS and insured that the virtualization was turned on & tried to launch the Virtual Machines and they opened.

So give it a try, if you are stuck with the following error while trying to open a Virtual Machine!

Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

regards,

rajesh