Oracle Weblogic | Reports 11g | cgicmd.dat | Key mapping issues

January 16, 2016

 

Hi guys

I’ve been installing and configuring Weblogic 10.3.6 & 12c (recently) and came across a peculiar issue, where the reports server failing to map the keys I’ve specified with cgicmd.dat file.

The best I could recollect from my memories was, I only added the keys to a single instance of cgicmd.dat file, as there are many instances of the same file once after classic domains are created.

Under linux installations you will find the file in 3 different locations once after the domain created and WLS_REPORTS server started.

 

[root@wls Middleware]# find /u01/Oracle/Middleware/ -name cgicmd.dat
/u01/Oracle/Middleware/user_projects/domains/ClassicDomain/servers/WLS_REPORTS/tmp/_WL_user/reports_11.1.2/uxabaw/configuration/cgicmd.dat
/u01/Oracle/Middleware/user_projects/domains/ClassicDomain/config/fmwconfig/servers/WLS_REPORTS/applications/reports_11.1.2/configuration/cgicmd.dat
/u01/Oracle/Middleware/Oracle_FRHome1/reports/conf/cgicmd.dat

[root@wls Middleware]#

image

Under usual scenarios you need to add the keys ONLY to the cgicmd.dat file present in

/u01/Oracle/Middleware/user_projects/domains/ClassicDomain/config/fmwconfig/servers/WLS_REPORTS/applications/reports_11.1.2/configuration/

folder.

With my latest installations of 12c & 11g, I had issue getting the keys mapped properly & after loads and loads of googling I decided to add the same key to all available instances of cgicmd.dat one after another.

So I started with the first instance of cgicmd.dat file, that was found under

/u01/Oracle/Middleware/user_projects/domains/ClassicDomain/servers/WLS_REPORTS/tmp/_WL_user/reports_11.1.2/uxabaw/configuration/cgicmd.dat

which is WLS_REPORTS temporary folder. I added the key, restarted the WLS_REPORTS server & the key was mapped as required!

This could be a nasty bug because I don’t remember adding the keys to multiple files while I tried out forms and reports 11g Release 2 almost 2 years back!

The most interesting part of the entire exercise is, once the key mapping happens successfully, you can remove the keys from cgicmd.dat file that in the temporary location and everything works! Could be the magic of cache Winking smile

So if you come across key mapping issues, you know where to look at for a quick fix.

for Windows7bugs

rajesh


Windows 10 64Bit | Install & Configure Weblogic 10.3.6 (64Bit), Developer Suite 11gR2 using JDK 7.x

October 8, 2015

Update (19th October 2015): I’m yet to find proper solutions for screen capturing in Windows 10. My favorite OBS doesn’t render the dropdown menus while screen recorded (thread here). Once it’s done, I will make the video as promised with my last update.

Update (12th October 2015) : I’m not promising, however, if possible, I will soon post a video with my Youtube channel explaining how you can configure both forms and reports server for hosting applications. Stay tuned :)

Hi guys

There are excellent articles explaining installing WebLogic 10.3.6 64Bit on Windows. Most of the installation methods are applicable to Windows 7, 8.x & on Windows 10 also. I opted to do a factory reset (the new reset option available with Windows 10) and was forced to re-install & configure WebLogic. I thought of sharing my experiences with you, as usual :)

(There were not a single hiccup experienced throughout the installation, to say it short)

Environment: Windows 10 Professional 64Bit, i5 Processor, 8GB memory, 1TB HDD, Dell laptop

Update 12th October 2015

Weblogic server 10.3.6 has identified issues with IPV6, hence I will suggest you to disable it in case if you are expecting a better experience with your Weblogic servers (forms & reports). ISA, the firewall client also could be a problem.

Once the IPV6 disabled, if you are in a home network or domain network, ping your machine and make sure that your ping replies are coming from your IPV4 address, instead of IPV6. If your computer is a domain member, ask your administrator to delete the IPV6 DNS entries for your box, disable IPV6 in your computer and restart. Ping again to confirm the replies are from IPV4. The issues are random, I had my Windows 8.1 machine with both the protocols enabled and my Weblogic servers just ran smoothly, however my Windows 10 box was adamant and until I disabled IPV6, couldn’t get the report server functional properly.

Step 1

Install JDK 7 to a folder without spaces in between, preferably C:\ (eg: C:\jdk or D:\jdk). Avoid installing JRE that comes with the JDK package.

Step 2

Copy your WebLogic installation .jar file to a folder (eg: D:\downloads)

Step 3

Now kick start the installation, as seen with the below image. It may take a while to deflate the .jar file and the installation to start

1

1a

2

Try to install the weblogic server in a folder that doesn’t have spaces in it’s name. I always installed it in D:\weblogic

3

You don’t have a support for the product most of the times, so uncheck the “I wish…”

4

5

6

7

8

Choose the “Typical” for install type

9

As you started the installation from the JDK installation folder, the local JDK will be already chosen

10

Select the defaults for components installations(unless you know how to handle it thoroughly)

11

Install WebLogic for all users

12

13

14

15

Uncheck “Run Quickstart” and exit the installation by clicking the Close button

16

Step 4 – Install Developer Suite 11gR2

Installation media for Developer Suite 11gR2 comes as 3 disks. Download (if still available) and start the “Setup.exe” from Disk 1

1

2

3

4

Select “Skip Software Updates” which requires a paid support from Oracle. If you have one, please set it up prior going ahead with the installation

5

Select “Install Software – Do Not Configure”. We’ll configure it as part of our Classic Instance setup.

6

You can ignore the error, details mentions about unsupported operating system, well that’s all our intentions

7

Unless you have specific requirements, accept the defaults

8

You don’t have a paid support from Oracle, you don’t get updates. Uncheck “I wish to …”

9

10

The installation will start now and it takes quite a while, in my case around 30 minutes. Sit back and relax

11

12

13

Exit the installation clicking “Finish” button.

14

Step 5 – Configure a Classic Instance

Even though you have installed Developer Suite 11gR2, you cannot yet use the development tools unless a classic domain is set up. Below please see how a classic domain is configured with Developer forms and reports.

A default installation of Oracle Developer Suite should create a folder “Oracle Classic 11g -Home1” under programs. You can activate the classic home setup by invoking menu item “Configure Classic Instance”

(I’m using ClassicShell start menu, I can’t really work with the latest “Start Menu”, so don’t get confused with the below image. You can use the search to find “Configure Classic Instance”)

0

0a

1

Select “Configure for Deployment”

2

Skip the below by unchecking the “I wish to …”

3

4

Unless mandatory, accept the defaults

5

Provide a alphanumeric password for “weblogic” account for the domain. Please note it down, incase if you fear of forgetting it (I do many times)

6

Important: By default “Oracle Forms and Reports 11g R2” is unchecked, You must check this option to install the developer tools. After checking, proceed with the configuration

7

Select “Auto Port Configuration”

8

Select “Do not use proxy settings”. Proxy settings could make weblogic experiences cumbersome. I suggest you use a computer that doesn’t require proxy settings

9

We are not going to use the Identity store for a local development machine, if you do, please provide the details.

10

Initiate the configurations by clicking “Configure” button

11

Configuration should complete in around 30 minutes, so sit back and relax

12

13

14

15

16

The above concludes the installation of WebLogic Server 10.3.6 & Developer Suite 11gR2 64Bit on Windows 10.

You can access the WebLogic server console by visiting http://localhost:7001/console/login/LoginForm.jsp

Let us checkout few essentials those will make sure that you have a seamless experience with the fresh installation.

Unlike the 32Bit, 64Bit installation of WebLogic server doesn’t install node manager Windows service. So you must install the windows service using the scripts provided by the installation process. If you didn’t change any of the default paths while installing the WebLogic server, the node manager windows service installation script file will be available …\wlserver_10.3\server\bin path

Best practice

Shutdown all running servers using the WebLogic console and restart the computer, this will avoid any sort of complication that could arise while the below exercise are executed.

From an elevated command prompt, running “installNodeMgrSvc.cmd” script will create this node manager windows service for you, which is mandatory for the WebLogic console to maintain your forms & reports servers (start, shutdown)

Once you created the node manager service, you should create a service for WebLogic admin server as well. This will help you from running the batch files manually & having a cluttered desktop later. More than, once created these services can restart themselves whenever you restart the box!

echo off
 
SETLOCAL
 
set DOMAIN_NAME=ClassicDomain
 
set USERDOMAIN_HOME=D:\WebLogic\user_projects\domains\ClassicDomain
 
set SERVER_NAME=AdminServer
 
set WL_HOME=D:\WebLogic\wlserver_10.3
 
set WLS_USER=weblogic
 
set WLS_PW=pass123
 
set PRODUCTION_MODE=true
 
set MEM_ARGS=-Xms512m -Xmx512m
 
call "%USERDOMAIN_HOME%\bin\setDomainEnv.cmd" 
 
call "%WL_HOME%\server\bin\installSvc.cmd"
 
ENDLOCAL

Copy the above script to a text file and save with a name like “InstallAdminServer.cmd” or with a name that ends with .cmd extension. I will always prefer saving the file in the same folder where we had the node manager service installation script.

Now, from an elevated command prompt, run the script, which should create Admin Server Windows Service for you.

srvc

If you followed the instructions, you should see all the services as listed above. You can start the ones which are not running, Please wait a while before trying to access the WebLogic admin console after starting the service. It takes few minutes for the admin server to come online.

I do hope this post will help you to install and configure WebLogic Server and Developer Suite 11gR12 on Windows 10 successfully. Have questions or problems? please update me with the comment section.

for Windows7bugs

rajesh


Oracle Weblogic Server 10.3.6, Configure Reports 11g(11.1.2) 64Bit

March 3, 2014

 

Howdy guys? We were busy upgrading uninstalling Weblogic 10.3.6, Forms & Reports 11g R1 and installing 64bit software throughout last few days.

For the installation part, you are not going to get better write up than one available here

However the installation procedure described there is limited to installing the Weblogic Server. You may refer to our earlier post for a “know how to” install and configure Forms & Reports 11g (both R1 & R2)

We tried the following combinations

Weblogic 10.3.6 64Bit with Forms & Reports 11g R1 32Bit. The results were quite disappointing. Installation and configurations went all fine, however once after a restart, we were not able to start the OPMN, thus all the services depending upon OPMN were failing. Even the uninstallation process was terminating without giving any prompts, forcing us to physically remove dozens of entries from registry and other places

Then we opted for a full 64Bit installation, which went smooth and after a restart everything was in place! intact

Setting up the forms using Oracle Enterprise Manager (R2 sets it up properly, against R1)

Just logon to Oracle EM, go to forms node and make changes and just apply. Many changes may not even require a server restart.

Few examples here

Forms node

image

Configuration Options

image

Web Configuration for “default”

image

Setting up LOV buttons, required field highlighting

image

Calling forms based applications once after the above are set is quite easy. Just point your browser to

http://hostname:8888/forms/frmservlet?form=login.fmx&userid=apps/apps@orcl

or

http://hostname:9001/forms/frmservlet?form=login.fmx&userid=apps/apps@orcl

However, calling a report may not be that easy. The report server(s) are pretty much sensitive to your network settings. For example, we are using one Windows 8.1 64Bit machine for the entire testing and on which we have multiple oracle products installed

To make the scenarios once again complex, we have both class C and Public IPs set as static addresses for testing multiple products at the same time and VirtualBox’s own network interface (disable it!)

We will try to analyze the most common errors one may come across while trying to run reports

REP-52005: The specified key <keyname: in our case the key userlogin> does not exist in key map file.

Web.Show_Document(‘/reports/rwservlet?userlogin&server=rep_wls_reports_rt03_prod_instance&desformat=PDF&destype=cache&report=’||:CTRL.REPORT_NAME||’&paramform=Yes’,’_new’);

Solution: http://docs.oracle.com/cd/E23943_01/bi.1111/b32121/pbr_run013.htm

Browse and locate file “cgicmd.dat”. You must take a backup and add the keyname and value by the bottom of the .dat file.

Eg: Physical path(Change according to your installation)

D:\Weblogic\Middleware\user_projects\domains\appsdomain\config\fmwconfig\servers\WLS_REPORTS\applications\reports_11.1.2\configuration

image

Save & restart the report server. Make sure you check the OPMN status as well. If required, restart OPMN by issuing opmnctl stopall & opmnctl startall from the application instance bin directory

opmn

The “opmnctl status” will provide you the status of element and make sure “RptSvr_<hostname>_asinst_1 is “Alive”

Go to Weblogic Server console and restart the WLS_REPORTS. Test your report once again.

REP-51002: Bind to Reports Server <servername> failed

This error could be genuinely difficult to address, as the log files will show the report server(s) and up and running, however keeping on failing to bind while trying to print reports.

Reason#1: Binding fails to resolve the hostname where the report server is installed. Mostly happens while the host has more than one static IP assigned

Solution:Edit C:\Windows\System32\Drivers\etc\hosts file and add an entry like following

Your.static.ip.address fqdn hostname

192.168.0.10      myhost.mydomain.com myhost

112.11.10.23      myhost.mydomain.com myhost

Reason #2: Windows firewall is blocking UDP against port 14021.

Solution: Create an exception with the firewall, or disable the firewall completely and try the reports once again. Please note, a restart of the box is always recommended

REP-52266: The in-process Reports Server <server_name> failed to start.oracle

Solution: This is mostly due to the host resolve issues. Once you resolved the issues as mentioned just above, the in-process server must be running fine after a restart.

Make sure the in-process Report server is up and running.

Update: There are couple of topics discussing about in-process report server, which should give you more details about how the server gets activated and when

https://community.oracle.com/message/9244290

http://docs.oracle.com/cd/E12839_01/bi.1111/b32121/pbr_strt006.htm

(We will do more tests and confirm the reasoning with our next update)

 

In-process reports server caters your web.show_document calls without a server parameter call. Let us check, how reports are called from a forms module, attached with a button click

Web.Show_Document(‘/reports/rwservlet?userlogin&server=rep_wls_reports_rt03_prod_instance&desformat=PDF&destype=cache&report=’||:CTRL.REPORT_NAME||’&paramform=Yes’,’_new’);

The first method, we are specifically passing the report instance name, while the below example

Web.Show_Document(‘/reports/rwservlet?userlogin&desformat=PDF&destype=cache&report=’||:CTRL.REPORT_NAME||’&paramform=Yes’,’_new’);

just tries to call the available report instance to cater the report. If you want to know how many reports instances are up and running in your server, you can use the EM or rwdiag.bat –findAll command

 

Common configurations for Reports 11g(11.1.2)

image

 

image

 

image

Leave alone the below

image

Additional settings (if required)

image

image

We are hoping to detail this post in near future. Too much typing for a day! Please note, these testing and solutions provided here are coming from novice like you guys, hence if you find anything which is not technically correct, please do let us know through comments section.

for Windows7bugs

admin


Uninstall Weblogic Server 10.3.6 & Forms, reports 11g

February 27, 2014

 

Quite a times, uninstalling Oracle products from a development machine could be quite troublesome, many times with errors difficult to understand. One of the most common errors

One of the most common errors as below

Thread: https://community.oracle.com/thread/2578042?start=0&tstart=0
—————————

Oracle Universal Installer

—————————

The Java RunTime Environment was not found at C:\DOCUME~1\v859971\LOCALS~1\Temp\OraInstall2013-09-05_01-10-08PM\jre\bin\javaw.exe. Hence, the Oracle Universal Installer cannot be run.

Please visit http://www.javasoft.com and install JRE version 1.3.1 or higher and try again.

A Discussion about the same here:

http://stackoverflow.com/questions/17282283/oracle-setup-exe-space-sensitivity-when-specifying-jre-absolute-path

Here is a quick workaround to address such situations

Copy the latest jre installation to a path without spaces

image

to, eg: C:\jre6

Switch to the folder where you have the “setup.exe”

C:\WINDOWS\system32>d:

D:\>cd D:\WebLogic\Middleware\oracle_common\oui\bin

Check what are the switches supported by the “setup.exe”

D:\WebLogic\Middleware\oracle_common\oui\bin>setup.exe -jreLoc C:\jre6 –help

Now, start uninstall process by starting the “setup.exe” with required switches

D:\WebLogic\Middleware\oracle_common\oui\bin>setup.exe -jreLoc C:\jre6 –deinstall

The setup GUI should start without throwing further errors now!

Once the components are uninstalled, you can uninstall weblogic server from “Oracle Weblogic” context menu, and the operation(s) should be smooth!

 

for Windows7bugs

rajesh


Upgrade your 11g Forms/Reports [32 Bit] Version 11.1.2.1.0 to 11.1.2.2.0

February 25, 2014

Upgrading Forms & Reports developer 11g could be equally confusing & interesting, as there are not many documents explaining a how to. Recently we were closely following up an “issue” raised by one of the visitors and opted to “upgrade” the development machine to check the feasibility of Forms & Reports 11g over Windows 8.1 64Bit

We were able to complete the upgrade process without much issues and the steps followed were described as below

Download the required software

http://www.oracle.com/technetwork/developer-tools/forms/downloads/index.html?ssSourceSiteId=null

image

As we were on 32Bit environment for the Weblogic, we downloaded the 32Bit packages for the upgrade. The total download should be roughly around 1.8GB

Once the downloaded archives are extracted, you can start with the upgrade process.

Prior the upgrade process, please make sure you stopped both Weblogic Admin server service & Weblogic Node manager service to avoid any kind of failures with the process.

 

image

image

You can kick start the upgrade process by executing the “setup.exe”

start

1

You should “Skip” the software update, as usual :)

2

Select “Install software – do not configure”

There could be multiple warnings about incompatible setups, you can “Safely” ignore and continue with the installation. We warn you, you shouldn’t install uncertified Oracle products on any OS, in case if you are going to use such setups for Production purposes

Setup should automatically pickup the “Middleware Home & Oracle Home Directory”

6

Going ahead will produce an error stating another installation is available in the selected location, ignore and continue

7

Unless you have a valid Oracle support contract, uncheck “I wish to receive…” and continue with the upgrade process

8

9

We got an error at 19%, all about certain java components. If you are familiar with LINUX, most of the times you could monitor a log file, as it is being updated using “tail” command. With latest versions of Windows OS you can use powershell to monitor the log file online.

Open up powershell and copy the installation log name like following

get-content “C:\Program Files (x86)\Oracle\Inventory\logs\install2014-02-24_12-59-08PM.log” –wait

It does the job and if errors are found, go ahead and cancel the installation and start over, which should deal with the java related errors. The total installation will be stuck unless.

image

10

11

12

 

13

14

You may save the setup steps and try out your upgraded forms & reports now. The only one element what we have noticed as “created” new as part of the installation was

image

Start Forms designer and check the about window and you must having the following information.

Forms [32 Bit] Version 11.1.2.2.0 (Production)
Oracle Toolkit Version 11.1.2.2.0 (Production)
PL/SQL Version 11.1.0.7.0 (Production)
Oracle Procedure Builder V11.1.2.2.0 – Production
PL/SQL Editor (c) WinMain Software (www.winmain.com), v1.0 (Production)
Oracle Query Builder 11.1.2.2.0 – Production
Oracle Virtual Graphics System Version 11.1.2.2.0 (Production)
Oracle Tools GUI Utilities Version 11.1.2.2.0 (Production)
Oracle Multimedia Version 11.1.2.2.0 (Production)
Oracle Tools Integration Version 11.1.2.2.0 (Production)
Oracle Tools Common Area Version 11.1.2.2.0
Oracle CORE 11.1.0.7.0 Production

That’s it folks. Give it a try and post us your issues, success notes.

for Windows7bugs

rajesh


Oracle Weblogic 10.3.6, Recreating Node Manager Service, Weblogic Admin Console Services after Windows 8.1 upgrade

November 3, 2013

We have recently noticed something very interesting about Oracle’s services were absconding (means not to be seen) from Services listing, however the Oracle products are intact in all other means.

Earlier we shared a post explaining recreating the missing database services. Today we will try to explain how you can recreate missing Weblogic services. You MUST have Administrative access to the box, and en elevated command prompt (right click, start as administrator)

Assuming you have installed the Weblogic 10.3.6 server in the folder “D:\WebLogic\Middleware>” let us start

Start an elevated command prompt. Switch to “D:\WebLogic\Middleware>”

Let us do an old DOS trick to print all the .cmd files available with the repository

D:\WebLogic\Middleware>dir *.cmd /s > D:\weblogic_cmd_files.txt

Double click open the weblogic_cmd_files.txt file you just generated. The file must have following entries

Directory of D:\WebLogic\Middleware\modules\org.apache.ant_1.7.1\bin

04/04/2013  09:04 AM             2,857 ant.cmd
04/04/2013  09:04 AM             3,410 antenv.cmd
04/04/2013  09:04 AM             4,315 envset.cmd
04/04/2013  09:04 AM             1,817 runrc.cmd
4 File(s)         12,399 bytes

Directory of D:\WebLogic\Middleware\oracle_common\bin

02/09/2011  04:39 AM             2,002 copyBinary.cmd
02/09/2011  04:39 AM             1,995 copyConfig.cmd
11/23/2010  11:40 AM             2,071 extractMovePlan.cmd
02/09/2011  04:39 AM             3,237 pasteBinary.cmd
02/09/2011  04:39 AM             1,985 pasteConfig.cmd
5 File(s)         11,290 bytes

Directory of D:\WebLogic\Middleware\oracle_common\common\bin

01/20/2010  04:11 PM               663 config.cmd
04/02/2010  03:36 PM               596 getproperty.cmd
01/20/2010  04:11 PM               661 pack.cmd
01/20/2010  04:11 PM               783 setHomeDirs.cmd
11/08/2010  10:30 AM             2,143 setNMProps.cmd
12/13/2011  03:41 PM             5,066 setOjbstEnv.cmd
12/13/2011  03:41 PM               315 setWasConfigEnv.cmd
01/20/2010  04:11 PM                62 setWasHome.cmd
12/13/2011  03:41 PM                93 setWlstEnv.cmd
11/08/2010  10:30 AM             1,593 setWlstEnvExtns.cmd
12/13/2011  03:41 PM             5,490 setWsadminEnv.cmd
01/20/2010  04:11 PM               663 unpack.cmd
05/09/2011  04:51 PM             5,865 was_config.cmd
01/20/2010  04:11 PM             1,684 wlst.cmd
05/09/2011  04:51 PM             5,903 wsadmin.cmd
15 File(s)         31,580 bytes

Directory of D:\WebLogic\Middleware\oracle_common\rda

09/16/2011  05:40 PM             7,266 rda.cmd
1 File(s)          7,266 bytes

Directory of D:\WebLogic\Middleware\Oracle_FRHome1\BIN

10/12/2012  03:22 PM             2,408 shortenPaths.cmd
1 File(s)          2,408 bytes

Directory of D:\WebLogic\Middleware\Oracle_FRHome1\common\bin

01/20/2010  04:11 PM               663 config.cmd
01/20/2010  04:11 PM               661 pack.cmd
01/20/2010  04:11 PM               851 setHomeDirs.cmd
01/20/2010  04:11 PM               663 unpack.cmd
01/20/2010  04:11 PM               558 was_config.cmd
01/20/2010  04:11 PM             1,388 wlst.cmd
01/20/2010  04:11 PM               655 wsadmin.cmd
7 File(s)          5,439 bytes

Directory of D:\WebLogic\Middleware\Oracle_FRHome1\opmn\bin

05/01/2008  05:27 PM               228 opmnassociate.cmd
1 File(s)            228 bytes

Directory of D:\WebLogic\Middleware\Oracle_FRHome1\rda

09/16/2011  05:40 PM             7,266 rda.cmd
1 File(s)          7,266 bytes

Directory of D:\WebLogic\Middleware\user_projects\domains\appsdomain

04/05/2013  11:39 AM               381 InstallWindowsService_AdminServer.cmd
04/05/2013  11:50 AM               534 InstallWindowsService_WLS_FORMS.cmd
04/05/2013  12:43 PM               524 InstallWindowsService_WLS_REPORTS.cmd
04/04/2013  09:57 AM               319 startWebLogic.cmd
4 File(s)          1,758 bytes

Directory of D:\WebLogic\Middleware\user_projects\domains\appsdomain\bin

04/04/2013  09:57 AM            22,511 setDomainEnv.cmd
04/04/2013  09:57 AM             3,348 startManagedWebLogic.cmd
04/04/2013  09:57 AM             5,945 startWebLogic.cmd
04/04/2013  09:57 AM             2,525 stopManagedWebLogic.cmd
04/04/2013  09:57 AM             1,989 stopWebLogic.cmd
5 File(s)         36,318 bytes

Directory of D:\WebLogic\Middleware\user_projects\domains\appsdomain\bin\server_migration

04/04/2013  09:55 AM             6,521 wlsifconfig.cmd
1 File(s)          6,521 bytes

Directory of D:\WebLogic\Middleware\utils\bsu

04/04/2013  09:05 AM               330 bsu.cmd
1 File(s)            330 bytes

Directory of D:\WebLogic\Middleware\utils\clone

04/04/2013  09:04 AM               338 clone.cmd
04/04/2013  09:04 AM               311 restore.cmd
2 File(s)            649 bytes

Directory of D:\WebLogic\Middleware\utils\config\10.3

04/04/2013  09:05 AM               182 setHomeDirs.cmd
1 File(s)            182 bytes

Directory of D:\WebLogic\Middleware\utils\quickstart

04/04/2013  09:05 AM               735 quickstart.cmd
1 File(s)            735 bytes

Directory of D:\WebLogic\Middleware\utils\uninstall

04/04/2013  09:05 AM               811 uninstall.cmd
1 File(s)            811 bytes

Directory of D:\WebLogic\Middleware\wlserver_10.3\common\bin

04/04/2013  09:05 AM             9,132 commEnv.cmd
04/04/2013  09:05 AM             2,079 config.cmd
04/04/2013  09:05 AM             1,512 config_builder.cmd
04/04/2013  09:05 AM             1,666 pack.cmd
04/04/2013  09:05 AM             1,422 setPatchEnv.cmd
04/04/2013  09:05 AM             4,873 startDerby.cmd
04/04/2013  09:05 AM             3,909 startManagedWebLogic.cmd
04/04/2013  09:05 AM             1,851 stopDerby.cmd
04/04/2013  09:05 AM             1,780 unpack.cmd
04/04/2013  09:05 AM             3,288 upgrade.cmd
04/04/2013  09:04 AM               773 wlsifconfig.cmd
04/04/2013  09:05 AM               580 wlst.cmd
12 File(s)         32,865 bytes

Directory of D:\WebLogic\Middleware\wlserver_10.3\common\derby\bin

04/04/2013  09:05 AM               206 startNetworkServer.cmd
04/04/2013  09:05 AM               104 stopNetworkServer.cmd
2 File(s)            310 bytes

Directory of D:\WebLogic\Middleware\wlserver_10.3\common\quickstart

04/04/2013  09:05 AM               243 quickstart.cmd
1 File(s)            243 bytes

Directory of D:\WebLogic\Middleware\wlserver_10.3\server\bin

04/04/2013  09:05 AM             3,275 installNodeMgrSvc.cmd
04/04/2013  09:05 AM             6,309 installSvc – Backup.cmd
04/22/2013  09:16 PM             6,468 installSvc.cmd
04/05/2013  12:11 PM             6,269 installSvc_WLS_REPORTS.cmd
04/04/2013  09:05 AM             3,882 setWLSEnv.cmd
04/04/2013  09:05 AM             5,085 startNodeManager.cmd
04/04/2013  09:05 AM               701 uninstallNodeMgrSvc.cmd
04/04/2013  09:05 AM               992 uninstallSvc.cmd
8 File(s)         32,981 bytes

Directory of D:\WebLogic\Middleware\wlserver_10.3\uninstall

04/04/2013  09:05 AM               226 uninstall.cmd
1 File(s)            226 bytes

Total Files Listed:
75 File(s)        191,805 bytes
0 Dir(s)  97,695,387,648 bytes free

If you really know where exactly the .cmd files are, you may go ahead with the rest of the exercises. So the Node manager installer script is residing under D:\WebLogic\Middleware\wlserver_10.3\server\bin folder. Switch to the folder and execute the .cmd file

image

D:\WebLogic\Middleware>cd wlserver_10.3\server\bin

D:\WebLogic\Middleware\wlserver_10.3\server\bin>installNodeMgrSvc.cmd

Executing the .cmd file should create a new service and available to start within services console.

image

So once we created the Node Manager Service, we can start re-creating the optional service(s). We will limit ourselves to Weblogic Admin Console service, which is the maximum for our exercises. You may refer to our other post about installing & Configuring Weblogic 10.3.6 for details about creating individual services for Forms and Reports services.

Based on the application domain(the directory export will clearly give you an idea of the folders where components are installed) you have chosen during the installation, switch to the domain folder now

D:\WebLogic\Middleware\user_projects\domains\appsdomain

Here is where you will find the scripts you have modified earlier during an installation cycle (following our earlier posts)

D:\WebLogic\Middleware\user_projects\domains\appsdomain>InstallWindowsService_Ad
minServer.cmd

D:\WebLogic\Middleware\user_projects\domains\appsdomain>echo off

…………

…………

D:\WebLogic\Middleware\user_projects\domains\appsdomain>ENDLOCAL

D:\WebLogic\Middleware\user_projects\domains\appsdomain>

Check your Windows Services console, and you must find a new service “beasvc appsdomain_AdminServer” listed

Bravo, let us check whether the newly created services are REALLY working once after they were freshly created.

Weblogic Admin Console

image

So we are done, let us start the Forms & Reports Servers now.

image

We hope this helps :)

for Windows7bugs

raj


Weblogic 10.3.6 Oracle Enterprise Manager(em) startup error “oracle.security.jps.wls.listeners.JpsApplicationLifecycleListener”

April 23, 2013

 

Oracle Enterprise Manager(em) allows you to configure, re-configure multiple elements for Oracle forms and reports repositories as well as other deployed applications.

EM is the GUI tool provided by Oracle to configure, say, look and feel for your forms instance. Instead of manually editing formsweb.cfg, default.env, registry.dat files, using the GUI you can configure the elements related those whole configuration files, to say the least.

A default installation of Weblogic 10.3.6 does include Oracle Enterprise Manager, however if you created a service for the Weblogic Admin Server using installSvc.cmd at later stages to start the Weblogic Admin Server, most probably the Enterprise Manager will not start automatically as JAVA classpath variable misses out certain elements, thus throwing the error

“Error java.lang.ClassNotFoundException: oracle.security.jps.wls.listeners.JpsApplicationLifecycleListener
Message icon – Warning Errors were encountered while performing this operation.”

After going through a number of OTN discussions, we managed to come up with a solution! by including “setDomainEnv.cmd” within installSvc.cmd batch file.

Please note, if you already created a windows service for Weblogic Admin Server, you must delete the service prior creating a new service. Once the service is gracefully stopped, go to elevated command prompt(Windows 8/ Windows Server 2008 Rx)  and type

SC DELETE “beasvc yourdomain_AdminServer”

Refresh the Services.msc console and make sure the service is deleted.

Now backup your installSvc.cmd file

We will modify the installSvc.cmd file (Location: example, D:\WebLogic\Middleware\wlserver_10.3\server\bin) like following (use a decent text editor like Notepad++ )

The following are the default entries you would find with “installSvc.cmd” file

@echo off
SETLOCAL


set WL_HOME=D:\WebLogic\Middleware\wlserver_10.3

call "%WL_HOME%\common\bin\commEnv.cmd"

Which we will modify like following

@echo off
SETLOCAL


set WL_HOME=D:\WebLogic\Middleware\wlserver_10.3

set ENV_HOME=D:\WebLogic\Middleware\user_projects\domains\appsdomain\bin

call "%WL_HOME%\common\bin\commEnv.cmd"
call "%ENV_HOME%\setDomainEnv.cmd"

Now go to folder, where you have created the .cmd file(s) for creating Windows services for

  1. Admin Server Console
  2. WLS_FORMS
  3. WLS_REPORTS

In our case we created all those “.cmd” files here

D:\WebLogic\Middleware\user_projects\domains\appsdomain

Now from the elevated command prompt

>InstallWindowsService_AdminServer.cmd (You can create the .cmd file with any name, we made it pretty descriptive for future references)

You may refer to our previous post, explaining how to install Weblogic Server 10.3.6 & Forms/Reports 11g for detailed explanation about creating Windows Services for Weblogic components.

Once the service is created, start it. Login to the console and check the status of “em” under deployments.

image

If the State is “Active” and Health is “OK”, your Enterprise manager is up and running. You can try to access the Enterprise manager from http://localhost:7001/em

image

You should provide the same credentials for the Weblogic Admin Console to login with EM.

image

From the EM Console, as said above, you can configure many parameters for Forms and Reports.

Even though you have managed to “fix” the EM access problem, there could be another issue, once after this exercise. You may not able to access the Forms or Report Server, though the Weblogic console shows them as running with Health being “Ok”

Stop the OPMN processes manually, and restart them and try again.

From elevated command prompt (if you haven’t sourced the environment variable for OPMN, change the working directory to, example: D:\WebLogic\Middleware\asinst_1\bin>)

and

  1. stop OPMN processes by issuing “opmnctl stopall”
  2. Check the status of the OPMN by issuing “opmnctl status”
  3. Wait until all the processes are stopped
  4. then restart the OPMN processes by issuing “opmnctl startall”
  5. Check the status and make sure all the processes are with a status “Alive”

That’s all guys. Hope you enjoyed our post.

regards,

Admin