Create Oracle Application Navigator Style Menu with Forms 6i

 

Okay, we are moving from Client/Server architecture to Weblogic+Developer 11g. One of the major requirements was to design and deploy a menu, which resembles Oracle application navigator.

We managed to design a menu, using LIST item (tlist) manipulation and the complete solution you can download from following link

https://skydrive.live.com/redir?resid=68080371B15625F8!128&authkey=!AEeoR-SI6z2WpjQ

We hope you will enjoy the solution.

 

Regards,

Admin

Install Oracle 10g onward database, developer on Windows 7

General Notice:

31st October 2019 (Final note on the topic, most probably)

As Windows 10 is maturing, Oracle Developer 10g 32Bit is having regular issues, most probably due to dynamic link libraries and function calls those are NOT any more existing or compatible. As we continue using Oracle E-Business Suite R12 with 0 plans to migrate as on date, the ONLY ONE solution left for us was to move the development stack to Windows XP Virtual Machines, on which the Developer Suite works as intended.

Please note, we don’t have solution for you, if you are trying to install Oracle database 10.1.x.x on Windows 7 or Windows 8. We apologize for a bit confusing title for this particular post which says “Install 10g onwards…” which is not literally true! Our tested database version was 10.2.0.3 and we were having the impression that all 10g releases had the same architecture.

We tried around a couple of dozen times to install 10.1.0.2 database on both Windows 7 (32/64bit) and on Windows 8, and every time the results were futile and we are resigning from future attempts :)

*Update* 11.Dec.2011

*Update* 13.Nov.2012

We are limiting this workaround method for Oracle Database versions 10.2.x.x and above, as one recent lab test proved that 10.1.x.x installation on Windows 7 never completing successfully. Run under compatibility mode set as OS version 5.1 (Windows XP Professional), failed to create database during the installation process, throwing Oracle error “ORA-12546”

This error looks like the same issues we had with Database 9i setup in the lab, apparently without any solutions. So, we guess it is time to move on :)

*Update* 21.Nov.2012

Looks like we are always on to the subject :) Anyway for those who guys have access to Oracle support, there is a happy news. The frequent crash experienced by Developer 10g forms are addressed to a greater level with an upgrade to 10.1.2.3.0 (patch number 5983622)

Noticed changes

  1. Forms doesn’t crash while opening form modules which are referring views, database objects like packages, procedures and functions WHILE NOT connected to database (Provided, minimum one time the forms developer was connected to the database, until a restart). Speaking English. Start developer 10g(patched), connect to database. Close forms developer and start it again, try to open forms modules without connecting to database until the computer restarts, you shouldn’t experience crashes.
  2. Quicker start-up, and the interface is ready to serve much faster than 10.1.2.0.2
  3. Installation has an option to override required OS version with y/n prompt

PART I (Install Oracle 10g on Windows 7)

Almost after more than year time, We still receive requests asking for assistance with installing Oracle 10g database while Oracle has 11g release 2 in place. We do understand why many need Oracle 10g against the latest released database and we confirm our claim once again YOU CAN INSTALL Oracle 10g on Windows 7 (Home Basic, Home Premium, Professional etc)

Though I believe the maximum number Oracle applications are accessed through Microsoft Windows clients, when the cooperation comes in, Oracle and Microsoft behave like sisters in a fight and the end users suffer!

As a Oracle developer it is my primary requirement to have a local database running from my laptop/desktop, having the oracle development tools properly installed and once I started with Windows 7, apparently failed miserably to get the Oracle stuff installed properly on Windows 7.

It took me almost 6 or more months to come against another wordpress blog where a user has posted a fix and frankly it WORKS

Before checking the workaround check what Chris F has to say

“Thanks.  This was helpful.  I noticed when installing the 10.2.0.4 server that even after changing the refhost.xml file, I was still getting the same version check errors.  I then had to go into the “install/oraparam.ini” file and change the certified version comma-delimited list there.  After that, the installer was happier.”

here is the work around.

Example, go to this folder “E:\Installers\Oracle_10g_1023\Disk1\stage\prereq\db”

locate the file “refhost.xml”, open it with notepad

you must see something like this

<CERTIFIED_SYSTEMS>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.0″/>
<SERVICE_PACK VALUE=”1″/>
</OPERATING_SYSTEM>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.1″/>
<SERVICE_PACK VALUE=”1″/>
</OPERATING_SYSTEM>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.2″/>
</OPERATING_SYSTEM>
<!–Microsoft Windows Vista–>
<OPERATING_SYSTEM>
<VERSION VALUE=”6.0″/>
</OPERATING_SYSTEM>
</OPERATING_SYSTEM>
</CERTIFIED_SYSTEMS>

now add the following:

<!–Microsoft Windows 7–>
<OPERATING_SYSTEM>
<VERSION VALUE=”6.1″/>
</OPERATING_SYSTEM>

within <CERTIFIED_SYSTEMS>   </CERTIFIED_SYSTEMS> tags, and the final entries should look like this

<CERTIFIED_SYSTEMS>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.0″/>
<SERVICE_PACK VALUE=”1″/>
</OPERATING_SYSTEM>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.1″/>
<SERVICE_PACK VALUE=”1″/>
</OPERATING_SYSTEM>
<OPERATING_SYSTEM>
<VERSION VALUE=”5.2″/>
</OPERATING_SYSTEM>
<!–Microsoft Windows Vista–>
<OPERATING_SYSTEM>
<VERSION VALUE=”6.0″/>
</OPERATING_SYSTEM>
<!–Microsoft Windows 7–>
<OPERATING_SYSTEM>
<VERSION VALUE=”6.1″/>
</OPERATING_SYSTEM>
</CERTIFIED_SYSTEMS>

Now run the Oracle installer and you would see the installation completes without giving any errors.

PART II (Install Developer Suite 10g on Windows 7)

Step 1 Setup Virtual Memory

Depending upon actual memory available with your computer, setup virtual memory. You can go upto double the size of actual memory while setting up your virtual memory. Please refer to the image(s) below

You would be asked to restart the computer and please restart.

Step 2 Setting up the Developer Suite 10g installer

Open the Disk 1 folder and locate “Setup.exe’

Right click “Setup.exe” and change the compatibility to Windows XP Service Pack 2 or 3

Step 3 Install Developer Suite 10g

Double click and start the installation, if you already have Sp1 installed and running latest Java runtime, you may come across PSAPI.DLL errors a number of times, caused by a function call missing information. You can safely ignore the warning messages and complete the installation.