Windows 8 | Wan miniport | device disconnected

For unknown reasons, the Wan miniport(s) available with Windows 7/8 could start showing errors & giving the user no apparent solutions to fix them, including uninstalling them.

I had the same situation when all of a sudden one of my PPTP connections started giving errors like “Device disconnected”, properties for the PPTP connection not shown and not allowing me to delete the connection in the corrupt state.

After few attempts, I came across a workable solution, posted with Microsoft support site. Unfortunately, this time I forgot to bookmark the page, however, still remember the entire steps. Please find them listed below

View – > Show hidden devices

1

Right click the Wan Miniport device with yellow exclamation mark

(Enlarge the images for more details)

2

3

4

5

Now force install the driver. Once the installation is over, you can safely uninstall this device. Follow the same for all the Miniport devices those are showing the exclamation mark. Once you are done with the uninstall processes, don’t do anything else. Just restart the computer and start creating the VPN connections once again.

The above exercises must have fixed the Wan miniport issues for you.

Regards,

rajesh

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: