VMPlayer, Sun VirtualBox installation on Windows 7 64bit

Had you try to install VMPlayer or Sun VirtualBox on your Windows 7 box yet? Okay let me tell you how I managed and what I didn’t manage until date.

Downloaded the latest version of Sun VirtualBox

The installation went smooth until 78-85% and a shortcut to the VirtualBox was created on my desktop and then the installer just stopped responding. I opened up the VirtualBox and everything seemed working okay. I created a Windows XP virtual machine, joined the same to our local domain and installed couple of most necessary software (Antivirus, IE8 etc) and was truly glad to have Windows XP back.

The joy didn’t survive a restart. Windows 7 restarting process hanged up for almost 8-10 minutes and given me a beautiful Bluescreen of death, told me it is dumping some information and then restarted. Once restarted the stupid error reporting started and the details pan clearly shown the information as “Bluescreen”.

With the last few BlueScreen experiences I was sure that Sun VirtualBox has made Windows 7 angry and I should get rid of the same the earliest possible or I will have more issues. I uninstalled Java VirtualBox and my beautiful Windows 7 professional 64bit once again become “STABLE”

However, I was feeling ditched and opted to download VMWare free player. The Installation file size was shows as 89MBs with the download site (OH yeh, as if the download procedure is so straight forward…check it out), when it downloaded it has shown as 92.xx MBs (who cares as far the download completed).

I started the installation without checking for compatibility issues, as the player was guaranteed to run on Windows 7. The installation went on for a while without throwing any errors and all of a sudden it prompted with an error message saying ‘UI.cab” could not be found. I checked with temp folder and I was able to see that the UI.cab file was intact. I searched about this error throgh google and found many entries mentioning about a corrupt downloaded file and about multi-layer file crunching.

THE ONLY WISE THING I DID WAS KEEPING THE DOWNLOADED FILE. Okay, I downloaded the installer again. Ran the installer and was given another error stating “Device.Cab” cannot be read because either the file is not existing or it is corrupt or blah!

One more thing I noticed while the installation started was, the package was extracting the file (though the exact location was not shown). I googled and found sequence like “downloaded installer -extract C:\vmplayer” to extract the contents of the installer to a physical location.

I extracted the FIRST DOWNLOADED installer to a location called “C:\VM1” and extracted the contents of the second downloaded installer to “C:\VM2”, then from “C:\VM1” I initiated the setup using “vmware player.msi”. Installation started and at the same point of time, I got an error saying the installer cannot find “UI.cab” file. I dared to copy the “UI.cab” from the “C:\VM2” folder and pasted over to “C:\VM1” folder and clicked on the “Retry” button and installation proceeded to next level, once again giving me an error for the file “core.cab”.

I did the same with what I had done for “UI.cab” and the installation progressed and I kept on copying files from C:\VM2 folder until the installation completed successfully. I still doubt whether the installation was 100% successful because I remember a flashing window where I was able to see a warning or error and before I could read the details, disappeared.

Anyway, I had the VMPlayer shortcut button on my desktop and it was fully operational (first time when I started the application the GUI didn’t load properly, however after couple of minutes time the VMWare GUI was ready for interactions). I installed Windows XP Professional and everything is working fine while writing this post.

Note: If you have a proxy which authenticates you to access internet, you may not able to successfully install the VMWare tools to your guest operating system as the download process will terminate stating ” incompatible database on the update server (41)”. So be ready with an alternative connection to internet if you really WISH TO HAVE YOUR VIRTUAL MACHINE IN FULL SCREEN MODE and with upgraded network connection speed etc. By default the VM will have 10MB connection speed and once you install the VMWare tools, the speed will be upgraded to 1.0GB!

Hope the provided information is useful for some others who are trying to install VMWare Player or Sun VirtualBox.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: