Installing Oracle Developer (forms & reports 6i) on Windows 7 64bit

Update (09.Feb.2012)

Just came across an issue while trying to install Developer 6i suite on Windows 7 64 bit (may apply to 32bi as well), came across following error “forms60.vrf(78):OS_ERROR while getting value Path”. Didn’t have a clue what was wrong as we were able to install Developer Suite 6i more than multiple times (for legacy application used across corporate)

Googling around brought us to this link and found the solution! It was related the path element length, by removing some “unwanted” entries from the path string, we were able to successfully install the Suite.

 

 

Oracle developer 6i (forms & reports) Installation tips.

Including me, many of you out there must be still using the developer 6i and getting this stuff work under Windows 7 64bit environment could be quite tricky.

Run the installer normally (without changing the compatibility mode) and finish the installation for both forms and reports. Go to this link and download the files suggested.

Now go to your developer installation folder, browse to BIN directory and make backups for these files

  1. NN60.DLL
  2. NNB60.DLL

Now copy the extracted files from the downloads you already have, to \BIN directory. This should deal with forms developer not responding to the “Run” button click or ‘Ctrl+R’ shortcut key.

Hope this post is useful Oracle developers.

About these ads

77 Responses to Installing Oracle Developer (forms & reports 6i) on Windows 7 64bit

  1. I have no problem with the forms, but when I require compile reports 6i, the program closes, please help

    • windows7bugs says:

      Hello Gustavo
      Had you installed the lastest available patches for Developer 6i? Unfortunately I am not in a position right now to clearly identify why your report developer is crashing while compiling. Would try to provide you a solution incase if you would forward me the Version details of your Developer 6i installation.

  2. Rodolfo says:

    Agradecería cualquier idea q me ofrezcan ya que no puedo instalar developer 6i en wondows(64) 7

  3. [...] Installing Oracle Developer (forms & reports 6i) on Windows 7 64bit March 20104 comments 3 [...]

  4. Vikram says:

    Thanks for the information.

  5. Nahid says:

    while I am trying to connect Database 10g throuh Oracle Developer (Forms/Reports) 6i but it could not connect.

    • windows7bugs says:

      Did you create the TNS entries? Once you install developer suite you must create an entry for the database with your “tnsnames.ora” file.
      You can find this file under “X:\orant\NET80\ADMIN” (X is the drive where you installed the developer suite)

      You can copy the tnsnames.ora file from your database installation folder and replace the existing one under “X:\orant\NET80\ADMIN”

      HTH

  6. CUONG says:

    ai co ban developer 6i cho toi xin 1 ban de cai

  7. Rawia says:

    I replaced the file mentioned above but still have the same problem

  8. Salman says:

    hi
    how to connect oracle xe 11g with oracle forms 6i?

    • windows7bugs says:

      It should be straight forward, just copy the tns entry for XE database from your system, paste it with forms 6i tns entry file (tnsnames.ora)

      Regards,
      Admin

      • Salman says:

        I tried it but some error comes and forms designer just close.
        error:
        Problem signature:
        problem event name: APPCRASH
        application version: 6.0.8.27
        application timestamp: 44201be2
        Fault Module name: ORA805.dll
        fault module version: 0.0.0.0
        fault module timestamp: 3b1f22b0
        exception offset: 000b4f04
        os version: 6.1.7600.2.0.0.256.1
        etc….

        now what should i do? please help me out in this regards.

        Thanks

  9. windows7bugs says:

    Hi Salman, it looks like you are using Windows 7 from the OS string supplied.
    Under normal conditions you shouldn’t have any issues with Developer 6i suite installation and further actions like developing forms and running them. Did you change the .dll files mentioned with the post? Do you have any patches already installed for the developer suite 6i?
    If you still having issues with the forms, we identify it as a unique situation and will not be in a position to provide you further assistance as we may need to have physical access to your situation :)
    Still, care about a fresh installation of Windows and re-installing the Developer suite once again with all suggestions we made with this post?

    Regards,

    Admin

  10. Salman says:

    Hi,
    firstly thanks for positive response.
    i have tried all in this post, like two dll files and patch set 17, 18, 19. on OS win 7 ultimate 32 bit. and using oracle express 11g.
    but forms 6i is running oracle 11g enterprise on win 7 home.

  11. Salman says:

    hi
    now i just for try uninstall oracle xe 11g and install oracle xe 10g “Oracle Database 10g Express Edition (Western European)” its just fine working on same windows “win 7 ultimate 32bit.
    is there any setting to do for xe 11g?
    i just send it to you tnsping on next post.

  12. Salman says:

    TNS Ping Utility for 32-bit Windows: Version 11.2.0.2.0 – Production on 09-JAN-2
    012 12:16:58

    Copyright (c) 1997, 2010, Oracle. All rights reserved.

    Used parameter files:
    C:\oraclexe\app\oracle\product\11.2.0\server\network\admin\sqlnet.ora

    Used TNSNAMES adapter to resolve the alias
    Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = Sam-PC)(
    PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE)))
    OK (0 msec)

  13. windows7bugs says:

    Hi Salman
    If the 10g XE database is connecting without any issues from same box, it must be something with 11g which is blocking the connection, or causing module crashes.
    Unfortunately,we test all our scenarios against enterprise database releases and we don’t have any means to test the scenario you have described.
    If we get a chance to test your scenario in near future, we will be more than happy to let you know the outcome.
    Until then, keep on “googling” to find out a solution or for answers to your conerns why 11g connection attempt fails.

    Regards,

    Admin

  14. Salman says:

    Thanks

    • windows7bugs says:

      Hi Salman
      We tested the scenario you described as an issue. Unfortunately, the 11g R2 expression edition refuses connection requests from Forms 6i (ORA80.dll crash).
      Apparently there are no work around solutions available right now, and you have to work with 10g Express edition, as forms 6i connects to 10g instances without any troubles.
      However, please note, we were able to successfully connect forms 6i to 11g R1 enterprise edition database without any issues.

      Regards,

      Admin

  15. narayan says:

    i am using oracle 10g with forms and reports 9i. i too have some issues in only 2 forms where the entire data entry is done. When i try to open these forms the program closes . All other forms (60) and reports (250) are opening in windows 7 32 bit.I had to copy the 32bit version of jvm.dll files to make oracle 10g work on windows7 32 bit. i happened to see this post and have downloaded the 2 dll files. i need a clarification regarding the patch 3 or17, 18 ,19 which is being said by many friends here. should i have to just copy these 2 dll files in developer suite bin folder or find out these patch set.

    • windows7bugs says:

      Hello Narayan
      Patch 18 is what we use with forms 6i which integrates the developer suite to our requirements. You should copy both the dll files to bin folder without fail in order to get the forms work properly (or this was our scenario)
      The forms which are failing should be recompiled (if you have the source files) once again to make sure that the modules work properly with the latest patch.

      Regards,

      Admin

      • narayan says:

        Hi,

        I have copied both the dll files in bin folder. I am using forms and reports 9i. what should be the patch which i need to use to integrate the developer suite and where to get the patch file.

        the forms do not open for me to compile it . the moment i open the file the program closes.

        i am not sure what is wrong

  16. narayan says:

    in contunuation of my previous post, i did copy the nn60.dll and nnb60.dll in bin folder. there was already one nn.dll folder which i did not remove.

    in any case the form which was not opening is still giving the same error with this message
    “oracle forms designer has stopped working and the program closes”

    could you pl help me out in this

    thanks in advance

    • windows7bugs says:

      Hi Narayan
      You should follow all the instructions provided with the workaround with our post, minimum to make sure that the forms 6i and reports would work.
      Refer to our previous reply to your post and do let us know whether recompiling the forms modules solved the issues.
      All the best!

      Regards,
      Admin

  17. Lasko says:

    Nice post Sir,
    I have an issue with Oracle Graphics Builder 6i on Win7. I can not start any report with graphics. There is a error “gobat60.exe has stopped working”. Do you have some experience with it?

    • Jigs says:

      Hi Lasko
      Did you solve your problem? As i am facing the same problem ..

      • windows7bugs says:

        Hello Lasko & Jigs

        As far we are aware, there are no workaround solutions towards graph issues with reports 6i while you are on Windows 7 or Windows 8

        The solution provided here is just for the forms and reports (without graph components)

        regards,

        rajesh

      • Jignesh says:

        Dear Rajesh,,

        I am looking for solution.. how to use grpah in 64 bit OS with help of form6i….. as in 32bit i am able to run graph thru form but 64 bit i m facing ‘gobat60.exe has stopped working” error…so will appreciate if some one can help me on it.

      • windows7bugs says:

        Hello Jignesh

        What did you mean by running from 32bit OS? You wanted to say 32bit Windows 7/8 OS or Windows XP?

        regards,

        rajesh

  18. windows7bugs says:

    Hi Lasko
    Unfortunately, No. We never had reports with graphs.

    Regards,
    Admin

  19. Lilly says:

    Hi,
    Thanks for the post.
    I’m having a problem with Developer 6i forms and reports on Win7 64bit , the forms works fine but the reports dont produce any report (give blank page and nothing is shown in the error log!also blank) before I copy the above DLLs I wasn’t able to connect to the database from the Reports builder but after copying them I was able to but still can’t produce the reports from the application! even I checked the oracle path and reports6o0 tmp in Registry but no luck! plzzzzz help :(

  20. windows7bugs says:

    Can you please let us know the patch applied for Developer suite 6i? Based on the provided details we may able to figureout your issues

    Regards,
    Admin

  21. Salman says:

    Run your application on forms 6i r2, but you can compile on this version 6.0.8.25.2 if required, because some feature can not run on r2 but r2 is running fine.

  22. Mazhar Ehsan says:

    Luckily there is no issue with the Win7 with the Oracle Developer Release 6.0

  23. larry says:

    the link for both file is not working?:(

    • windows7bugs says:

      larry
      You should be thousand times sure prior downloading .dll files from a private repository, anyway we did, so did many others as without these .dll files, we were helpless to do what we were supposed to at work.
      Let us see whether we can provide you access to these files, we will contact you soon through email and if replied will forward you the .dll files as attachments.

      regards,

      Admin

  24. ecalle says:

    hello i like install Forms & Reports 6i Release 2 for Windows but i dont have de installer anything can help? where i can download it

    • windows7bugs says:

      Hello ecalle
      Unfortunately, you will not able to download the installer packages any further from Oracle repositories. As developer suite installers are not widely used by others other than your best bet for the same would be finding some organizations still running Oracle client server applications, which are developed using 6i Development tools.

      Check this link as well http://www.filecrop.com/oracle-developer-6i.html

      We haven’t checked the repository, if the files are still available, do download at your own risk

      regards,

      admin

  25. [...] news for Oracle enthusiasts! You can even install Oracle Developer Suite 6i following the same trick we provided for Windows 7. Please refer the attached [...]

  26. mooncode says:

    I have no problem with form, but when I tried to print a report, it says : REP-1848 : Failed while trying to begin printing. I am using windows 7 pro x86 on client machine and windows server 2012 standard x64 on server machine, both have the same issue. Please help …

  27. windows7bugs says:

    Hello Moon
    Did you patch your 6i installation? Are those files replaced with the 2 dll files mentioned with the post?

    regards,
    admin

    • mooncode says:

      Yes, I’ve patch my 6i installation and I’ve replaced the two files above, I’ve also restarted the machine using windows 7, but, the problem is still occurred, any idea ?

  28. Arif Khadas says:

    The report was not working on 64 bit so I replaced the dll files and the report’s are working. Exception is one report which does appear but when clicked on Next Page the Report progess is “Formatting Page 1″ forever. Also to mention there is a Graph placed on this report.

    • windows7bugs says:

      Hi Arif
      You may have to develop the report from scratches :) (the one which is not working properly)
      Developer 6i is an obsolete product, not supported or certified to work with Windows 7 or Windows 8 and the solution provided by us is as it is. Without any claims that the solution is going to work in each and every other situation.
      For example, all our legacy applications are working perfectly with the given solution, and we do believe, many others are also using the same solution in production environment.

      regards,

      admin

  29. Grigoriy says:

    Thank you for that DLLs, but i still got the problem.
    When i “Run Form Client/Server” (ctrl+r) on old DLLs, i saw form compliling and just nothing more happens.
    Now, after replacing DLLs with new ones, i got form compiling AND THEN it tryes to open form in IFRUN! Compiled form screen borders appears and after a second – closes.
    That is not a compiling problem anymore, IFRUN cant launch it.
    Anyone know what to do?

    • windows7bugs says:

      Hello Grigoriy

      Can you please post us the forms developer version? Have you applied any patches after the default installation?
      The version we tested the solution provided here was “Forms [32 Bit] Version 6.0.8.27.0 (Production)”, ie, patch 18
      The next and last patch 19 was actually released for Application server 11x, not really applicable for client server architecture.

      Further we recommend you to do the following
      Develop a new form from scratches using emp table from scott schema
      Run it without adding triggers and custom codes. Does it run? or it crashes as you have explained.

      Is your Windows 7/8 box is fully updated? If you are on Windows 7, a majority of the stability issues were rectified and solved with SP1

      Please respond to our comment, so that we can suggest you solutions

      regards,

      admin

      • Grigoriy says:

        Ive got “Forms [32 Bit] Version 6.0.8.27.0 (Production)”
        I dont know about applyed paches – that PC was given to me as is.
        Same problem persist on any other form, as they all run in 32bit enviroment (on older PCs). As we have old PCs replaced with new ones (win7 64 pro sp1) – all our developers have same problem=\

        Is it possible, IFRUN60 lauched directly uses different pathes, rather than IFRUN launched from IFBLD60?

      • Grigoriy says:

        i mean, it seems like ifrun from ifbld cant be lauched, but when its launched directly – its ok and compiled form (fmx) runs Ok.

      • windows7bugs says:

        Hello again Grigoriy

        Well well, we are yet to come across this issue. ie, while replying to your comment, we are working on three or four projects using developer forms 6i, the same version what you are using, and run the forms using Ctrl+r key combinations

        We are also in the same mixed environment, using both Windows 7 SP1 and Windows 8 (all 64Bit machines)

        regards,
        admin

  30. saumya says:

    I get TNS no listener problem when i am connecting in form builder and reports too.. how to resolve this problem?

    • windows7bugs says:

      Which version of forms & reports you are using? Looks like you didn’t configure TNS entries for the developer suite. Easiest way would be to copy tnsnames.ora from your database installation path and replace the one available with your developer suite installation path.

      This method has a downside as you may lose already existing entries as the entire file will be replaced at developer side.

      Regards,

      Admin

  31. […] by Oracle developer 6i, even after your patch certain .dll files (refer to our previous post here […]

  32. Syntech says:

    Reports Background Engine displays REP-0501: Unable to connect to specified database and always requests for user id (username, password, database) before displaying already successfully complied report. I’ve applied the nn60.dll and nnb60.dll files to the \BIN directory of developer 6i installation home. I run developer 6i R2 application on windows 2008 r2 64-bit. I use Run_Product command to display the reports on windows 32-bit and it’s working fine. The forms are working fine once successful logon was applied.

    Regards.

  33. dude, if you have the problem while installation as OS error of getting value path that means that the environment variable path is more than 1031 character ,your solution is to backup all the paths included in this variable then make it less than 1033 character then install oracle developer 6i after that you get the old variable path you backed up,also after you install oracle 6i on win 7 64 bit you will need to install patch number 18 to insure the maximum performance and avoid any runtime errors.

  34. Karlis says:

    I had problem that if I change my workstation language to non-English Forms 6i builder crashes (the same for runtime)

    • windows7bugs says:

      Hello Karlis

      Those .dll files are coming from an earlier patch. This solution is a workaround, without guaranteed. We would appreciate if you could tell us why you need to change the base language for the OS.

      Regards,

    • Brecht says:

      Hi,

      did anyone here manage to get forms 6i (builder or runtime; patch 18) working with an 11.2.0.4 database? If so, how? We are unable to get that combination up and running: it just crashes as soon as one tries to connect to the database (and so does sqlplus). No problems with 11.2.0.3 though.

      Thanks,

  35. Brecht says:

    The 11.2.0.4 uses AL32UTF8 (and doesn’t work). The 11.2.0.3 uses UTF8 (and doesn’t work).

  36. Brecht says:

    Sorry, I meant the 11.2.0.3/UTF8 does work.

  37. Sarai says:

    I had some issues with iconic buttons where icons were displayed ok when running a form in runtime environment and where I did not see any custom icons (having them stored in a different folder) when designing or running forms from Forms Builder. UI_ICON registry key was set correctly.

    The problem was that IFBLD60.EXE had a check mark checked under “File Properties -> Compatibility: Run this program in compatibility mode”. After I unchecked it, I was able to see icons in Forms Builder.

  38. jorge says:

    Tengo corriendo Forms6i sobre windows 8 con Oracle 11G. Solo tengo problemas con los iconos. Antes se ubicaba el path en el regedit, pero ya no funciona. Alguna idea? Gracias

    • windows7bugs says:

      Hello Jorge
      No hablamos :) españolas De todos modos, he traducido la consulta y aquí viene algo que puede ayudarle.

      Tuve algunos problemas con los botones icónicos donde se visualizan bien los iconos cuando se ejecuta un formulario en el entorno de ejecución y donde yo no vi ninguno iconos personalizados (tenerlos almacenados en una carpeta diferente) la hora de diseñar o ejecutar formas de Forms Builder. Clave de registro UI_ICON se estableció correctamente.

      El problema era que IFBLD60.EXE tenía una marca de verificación marcada en “Propiedades del archivo -> Compatibilidad: Ejecutar este programa en modo de compatibilidad”. Después de que yo no se, yo era capaz de ver los iconos en Forms Builder.

      English

      I had some issues with iconic buttons where icons were displayed ok when running a form in runtime environment and where I did not see any custom icons (having them stored in a different folder) when designing or running forms from Forms Builder. UI_ICON registry key was set correctly.

      The problem was that IFBLD60.EXE had a check mark checked under “File Properties -> Compatibility: Run this program in compatibility mode”. After I unchecked it, I was able to see icons in Forms Builder.

      Este consejo fue publicada como un comentario con nuestro hilo se explica cómo instalar las formas 6i. Por favor, comprobar y confirmar si te ayudó

      saludos,

      rajesh

      (No puedo dar fe de la exactitud de la traducción hecha con la ayuda de google traductor, espero que así sea ayuda)

  39. Jadeja says:

    I am facing the problem with 6i in windows 7 64bit. Our ERP is client server base. While installing oracle client in windows 7 64bit forms doesn’t opens. It just blinks and disappears. I tried replacing DLL but still same.

    • windows7bugs says:

      You mean you cannot install at all or after installation you cannot open forms? Please confirm. If possible, please post us the Forms6i version number.

      regards,

      • Jadeja says:

        It is after installation. 1st Oracle client Forms & Reports Runtime (Forms/Reports Runtime + Oracle Installer + Net8 Products + System Support files + Required Support Files & Tools Utilities) These are the components selected. After that patch 1 + 13 + 19 installed. This is the setup we run in all PC.

        But the problem is only with 64bit OS. There it installs properly but when running application it just blinks and disappears.

        ORA runtime version is – 6.0.8.11.3

      • windows7bugs says:

        Hello Jadeja

        We know that the issues are ONLY with 64Bit, actually we are dealing with a product that is almost 14 years old as on date and Windows OS changed significantly during this period. Especially the 64Bit is relatively new and there is no guarantee that Oracle’s legacy software would work as expected from a newer OS.
        We are using Forms [32 Bit] Version 6.0.8.27.0 (Production), ie, patch 18. For testing we will suggest you to apply the patch 18, then replace the .dll files as specified with the post and update us.

        regards,

      • windows7bugs says:

        If you are wondering how to figure out the current patch version for your forms 6i, minus 9 from the 4th segment from the version. That is 11-9=2, a very old release!

  40. Jadeja says:

    I have tried with fresh installation + patch 18. No luck. It same. Application runs and gets close withing fluctuation.

    Please give some solution. My whole project is stuck because of this issue. thanks

    • windows7bugs says:

      Hello Jadeja
      Do you still have the source FMB files? If yes, make a copy of the fmb files, move to a fresh system, install forms 6i with patch 18 (replace the dll files), recompile the source files and see whether you can run the application.
      What further could be confirmed is, the hacking what we explained is/WAS never a permanent solution as you will not able to run the Oracle graphs using the hack we mentioned (Or it is what was reported) and stability issues like unexpected termination while browsing through huge master detail records.
      Please get back to us with the info whether you have access to the FMB files.

      regards,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 51 other followers

%d bloggers like this: